On 10/14/2013 09:28 PM, Amos Jeffries wrote:
>
> I think store_miss and send_hit are the best out of those above.
>
> The naming of HIT directive is a bit tricky, but the above is no more or
> less ambiguous than reply_from_cache.
> Perhapse "lookup" or "find", "seek" , "search" somethign along those
> lines? instead of send-hit or reply_from.
>
> cache_lookup allow/deny has a nice clear semantic to it.
>
> cache_store_miss
>
> Even cache_write / cache_read are somewhat close to the intended behaviour.
I like "lookup" for point 1!
Cache_store_miss for point 3 is usable, although having both "cache" and
"store" words in there is far from ideal. Either "cache_miss" or
"store_miss" would be better IMO.
We still need send_hit or some such for decision point 2 though, as
discussed earlier.
I suggest a consistent verb+noun scheme:
lookup_hit
send_hit
store_miss
If others insist on using cache_ as a common prefix, then I suggest a
consistent cache+noun scheme:
cache_lookup
cache_miss
cache_hit
All of which would be followed by the standard allow/deny actions and
ACLs. Each will be applied at its own designated decision point and have
minimum side effects.
A separate decision would be made whether to End-of-Life the existing
"cache" directive with its combined and overreaching side effects.
Cheers,
Alex.
Received on Tue Oct 15 2013 - 16:13:15 MDT
This archive was generated by hypermail 2.2.0 : Wed Oct 16 2013 - 12:00:12 MDT